1. Hello there guest and Welcome to Fox Body Mustangs forum, This forum is intended to be used by enthusiasts of the Fox body Ford Mustangs (1979-1993)!
    To gain full access you must Register. Registration is free and it takes only a few moments to complete.
    Already a member? Login here then!

    Dismiss Notice

1986 Ford Mustang GT

Discussion in '1979-1986 Four Eyed Mustangs' started by FoxBodyMustangs, Oct 10, 2012.

  1. FoxBodyMustangs

    FoxBodyMustangs Administrator Staff Member

    728
    249
    43
    [​IMG]
    Your Muscle Car Enthusiast Site​
    [​IMG]
    Click Image for Specifications​
    [​IMG]
     
    4eyeJay likes this.
  2. Calypso Coupe

    Calypso Coupe Active Member

    371
    195
    43
    Thats the dash bezel AND speedo I need :)
     
  3. 86foxcollector

    86foxcollector New Member

    11
    4
    3
    i may have the bezel just not the speedo
     
    Calypso Coupe likes this.
  4. Calypso Coupe

    Calypso Coupe Active Member

    371
    195
    43
    I like that bezel more than the plain grey one in the car. If u come across one that would be awesome. Im in no hurry for it just let me know if you find one. Thanks!!
     
  5. AT6svo

    AT6svo Member

    35
    30
    18
    That's a helluva clean 86. I like it.
     
  6. 88lx elmo

    88lx elmo CARNAGE 88 LX

    229
    126
    43
    Phil i my know some one that is about to start parting out there 86 with tones of parts it could have what u are looking for.

    his name is Joe i think you have meet him before... older guy with 2 tone GT pushing 950hp. let me know if you want his info.
     
  7. AT6svo

    AT6svo Member

    35
    30
    18
    Yes, unfortunately it appears that he is parting out a perfectly good car for no reason other than profit.

    I refuse to support assholes who do that. I will not be buying anything he has to sell.
     
  8. 88lx elmo

    88lx elmo CARNAGE 88 LX

    229
    126
    43
    I was told to much rust to fix...i know he had started the prep work for paint and in the prosses found the rust.
     
  9. AT6svo

    AT6svo Member

    35
    30
    18
    The pictures I saw showed rust where the 1/4s meet the roof, mostly on the interior, which is very common on 79-86 fox mustangs & Capris. My 81 has it, my 84 SVO did and my 86 does too. There was one hole behind the 1/4 panel louvers about 3/8 an inch in diameter. An hour or two with a wire wheel and a can of Eastwood's Rust Encapsulator would have done the trick. That's the easy fix. And for a "driver "which he claims it was. Of course the long term fix is to cut it out & weld. I've had much worse fixed.

    He has a lot of high dollar parts on the car. Its not the first car he has parted to make a buck.

    My applogies to the OP in this thread. I still think your 86 is a very nice example of the breed.
     
  10. Calypso Coupe

    Calypso Coupe Active Member

    371
    195
    43
    The car in this post is SUPER clean, time capsule.
     
  11. 88lx elmo

    88lx elmo CARNAGE 88 LX

    229
    126
    43
    its always sad to see a fox GO in pieces.
     
  12. 88lx elmo

    88lx elmo CARNAGE 88 LX

    229
    126
    43
    yes she is....
     
  13. Billyd1157

    Billyd1157 New Member

    1
    0
    1
    Ok I'm new to this forum well to any forum at all but I'm currently bamboozled by this particular problem I just recently purchased a 86 mustang gt the car is pretty well stock other then the upper and lower intake witch where replaced with gt40 setup the car is a non mass air flow car it has the tko 5 speed trans it starts up and runs good and drives even better but every now and then the car starts spitting and sputtering at first it was pretty dang bad but here's the messed up part if I flippd the switch off and flipped it back on itd fire up and run like a champ I've got i started off by running injection cleaner through the gas it ran a little bit better I decided to clean the iac bc it would stall at idle sometimes it would idle great right at 900 rpm then drop pick up drop pick up die cleaned iac the problem was still there so I figured maybe change the fuel filter wasn' that either previous owner changed plugs wires distributor and gas tank and fuel pump I'm very lost and any help being pointed in the right direction would be greatly.appreciated
     
  14. Redtwilight

    Redtwilight Shinigami

    44
    20
    8
    It could be a number of things from just a vacuum least, to a loose / bad ground, to bad TFI, or even ECM.

    Since the intake was replaced, check all the grounds, harness connections, and vacuum lines.

    Have you checked the fuel pressure? It's possible the fuel pressure regulator could be going. At worst, it could even be a capacitor or two in the ECM itself going bad.
     

Share This Page